Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress WordPress pages do not display correctly on clients after deploying new server

Discussion in 'Misc WordPress Requests' started by fitzgeraldk, Jan 23, 2018.

  1. fitzgeraldk

    Guest

    WordPress pages do not display correctly on clients after deploying new server, by fitzgeraldk

    I’ve just installed wordpress on one of my servers in my datacenter according to this walkthrough https://codex.wordpress.org/Installing_on_Microsoft_IIS

    I can login to the admin page when I’m logged in to the server and the sample page displays correctly on the server. However, when I browse to the webpage from a client pc then the page does not display images correctly and I’m not able to log in to the admin page. The admin page keeps redirecting to local link, instead of the server name.

    I’m wanting to host this myself since my company has a very robust datacenter/server environment, instead of paying someone else to host the webpage.

    Do I have to have someone else host a wordpress server? What do I need to do to get the pages to display correctly for everyone else? In the install documentation, it said it gets installed in localhost mode, do I need to change that so anyone can browse to the webpage?

    I’m new to wordpress but I’ve used and managed many other kinds of webservers for companies and had the web servers deployed on premise instead of in the cloud.

    Thank you for your help.

    WordPress pages do not display correctly on clients after deploying new server
     
    #1

Share This Page

Monarch Social Sharing Plugin