Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Your PHP installation appears to be missing the MySQL extension which is require

Discussion in 'Misc WordPress Requests' started by mdiehl, Mar 1, 2018.

  1. mdiehl

    Guest

    Your PHP installation appears to be missing the MySQL extension which is require, by mdiehl

    Hello,

    I’ve been tasked with migrating an existing wp installation to a new server. The new server is a CentOS 7.4 server running Apache 2.4.6.

    When I point my browser to the new site, I get:

    Your PHP installation appears to be missing the MySQL extension which is require

    However, when I run php -i | grep mysql , I get:

    =================================
    /etc/php.d/mysqlnd.ini,
    /etc/php.d/mysqlnd_mysql.ini,
    /etc/php.d/mysqlnd_mysqli.ini,
    /etc/php.d/pdo_mysqlnd.ini,
    mysql
    Client API version => mysqlnd 5.0.10 – 20111026 – $Id: e707c415db32080b3752b232487a435ee0372157 $
    mysql.allow_local_infile => On => On
    mysql.allow_persistent => On => On
    mysql.connect_timeout => 60 => 60
    mysql.default_host => no value => no value
    mysql.default_password => no value => no value
    mysql.default_port => no value => no value
    mysql.default_socket => /var/lib/mysql/mysql.sock => /var/lib/mysql/mysql.sock
    mysql.default_user => no value => no value
    mysql.max_links => Unlimited => Unlimited
    mysql.max_persistent => Unlimited => Unlimited
    mysql.trace_mode => Off => Off
    mysqli
    Client API library version => mysqlnd 5.0.10 – 20111026 – $Id: e707c415db32080b3752b232487a435ee0372157 $
    mysqli.allow_local_infile => On => On
    mysqli.allow_persistent => On => On
    mysqli.default_host => no value => no value
    mysqli.default_port => 3306 => 3306
    mysqli.default_pw => no value => no value
    mysqli.default_socket => /var/lib/mysql/mysql.sock => /var/lib/mysql/mysql.sock
    mysqli.default_user => no value => no value
    mysqli.max_links => Unlimited => Unlimited
    mysqli.max_persistent => Unlimited => Unlimited
    mysqli.reconnect => Off => Off
    mysqlnd
    mysqlnd => enabled
    Version => mysqlnd 5.0.10 – 20111026 – $Id: e707c415db32080b3752b232487a435ee0372157 $
    Loaded plugins => mysqlnd,example,debug_trace,auth_plugin_mysql_native_password,auth_plugin_mysql_clear_password
    API Extensions => mysql,mysqli,pdo_mysql
    mysqlnd statistics =>
    PDO drivers => mysql, sqlite
    pdo_mysql
    Client API version => mysqlnd 5.0.10 – 20111026 – $Id: e707c415db32080b3752b232487a435ee0372157 $
    pdo_mysql.default_socket => /var/lib/mysql/mysql.sock => /var/lib/mysql/mysql.sock
    =================================

    This seems rational.

    I have moved the old database over to the new server and am able to connect to it with a simple php script:

    <?php
    $mysqli = new mysqli(“localhost”, “wp_user”, “wp_passwd”, “wp_db”);
    if ($mysqli->connect_errno) {
    echo “Failed to connect to MySQL: (” . $mysqli->connect_errno . “) ” . $mysqli->connect_error;
    }

    echo “Run complete\n”;

    ?>

    Of course, I used the same credentials in wp-config.php

    So, I _think_ the system has all it needs.

    What am I missing?

    Thanks in advance,

    Mike.

    Your PHP installation appears to be missing the MySQL extension which is require
     
    #1

Share This Page

Monarch Social Sharing Plugin