Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix wp-admin files has no permissions

Discussion in 'Misc WordPress Requests' started by siritinga, Dec 29, 2017.

  1. siritinga


    wp-admin files has no permissions, by siritinga

    Dear group,

    A friend of mine has ask me to check his WP site that has no permissions to access wp-admin files for some unspecified reason. Users can log-in but if any user tries to access any file located in wp-admin, a message saying that the user has no permissions appears.

    I’ve tried every solution I found on Internet without success:

    * The main site loads fine, with all the styles and articles there, so the database can be accessed.
    * I have updated WordPress from commandline to 4.9.1.
    * Directories and files have the right permissions (644 for files, 755 for directories).
    * Tables prefixes seems to be fine.
    * I’ve tried to disable plugins (renaming the plugins directory) and restore a default .htaccess with no luck.
    * Users can log-in even if they get the page saying that they have no permissions for wp-admin pages. After logged in, I can go to the home page and I see the upper bar with commands like new post, add users, etc. but if I try to use any of them, then I get the no permission page.
    * I’ve checked the Admin permissions in the SQL database and seem to be fine.
    * wp-admin/about.php loads so the directory is accessible.
    * I’ve tried enabling the WP_DEBUG flag but the debug is not helpful.

    I’m running out of options of what to check next, any advice will be very welcome.

    Thank you!

    wp-admin files has no permissions

Share This Page

Monarch Social Sharing Plugin