Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix WordPress $is_nginx (et sim.) incompatible with mod_security

Discussion in 'Misc WordPress Requests' started by lllor, Feb 14, 2018.

  1. lllor


    WordPress $is_nginx (et sim.) incompatible with mod_security, by lllor

    Dear all,
    since my admin has enabled mod_security with SecServerSignature in order to overwrite the “Server:” field in http responses with a fake value, as a side effect the variables $is_nginx, $is_apache, $is_IIS etc. in wordpress are set to a wrong value.
    (they actually read $_SERVER[‘SERVER_SOFTWARE’] in order to discover server type)

    are there other ways within wordpress for identifying the right web server?

    Kind Regards,

    WordPress $is_nginx (et sim.) incompatible with mod_security

Share This Page

Monarch Social Sharing Plugin