Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Weird Permissions-Related [?] Issue with Visual Editor [TinyMCE]

Discussion in 'Misc WordPress Requests' started by WordPress.org Forums », Feb 19, 2018.

  1. WordPress.org Forums »

    Guest

    Weird Permissions-Related [?] Issue with Visual Editor [TinyMCE], by

    This is a strange one.

    I got contacted today by the owner of a WordPress site I Administer. He said that he wasn’t able to edit posts any more, as the edit window was empty. When I logged in to the site as him to test, I found the old familiar situation whereby the TinyMCE buttons don’t load above the edit window and, while it looks like the edit window is empty, it’s actually got the content there –just white text on a white background.

    Now, there are a million posts about this on the internet and I ran through all the usual remedies:

    * Update themes
    * Clear cache
    * Disable plugins
    * Install Google Libraries plugin
    * Add define( ‘CONCATENATE_SCRIPTS’, false ); to wp-config
    * Replace wp-includes'js/tinymce/ with a fresh copy.

    None of which worked, when I logged in as the site user and tried to edit any of his posts.

    However, whilst I was making the above changes [which required me logging into WP as the Administrator], I happened to open an edit window and found everything was working properly. I then upgraded the site owner’s role from Editor to Administrator and logged in as him and his edit window was restored in all its TinyMCE glory. When I changed his role back to Editor again and we were back to a blank editor again.

    So I’m a bit baffled here, trying to figure out what can the root of the problem be? Obviously something has happened whereby the Editor user of the site no longer has the necessary privileges to load the visual editor. But how can this have happened and how do I resolve it?

    This issue just developed today. However, I did do an upgrade of WordPress from 4,9,3 to 4,9,4 last week, so it seems that *something* went wrong there [This is the first time the owner has tried to use the edit window, since the upgrade]. But I’m not sure how I’d go about fixing the Editor user role so that it has access to TinyMCE again.

    Any ideas?

    Weird Permissions-Related [?] Issue with Visual Editor [TinyMCE]
     
    #1

Share This Page

Monarch Social Sharing Plugin