Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Unable to update plugins

Discussion in 'Misc WordPress Requests' started by robyone3170, Oct 26, 2017.

  1. robyone3170

    Guest

    Unable to update plugins, by robyone3170

    Hello,
    On a server with Centos 6.9 (Apache 2.2.15, PHP 7.1.6) I installed a site with wordpress 4.8.2, but I can not update or install plugins!

    When I try, I get the following errors (widt WP_DEBUG=true).
    This is trying to update a Cherry plugin, for example, but do it with everyone:

    Warning: rename(/wp-content/upgrade/v1.0-nTh35W/CherryFramework-cherry-social-11de820/,/wp-content/upgrade/v1.0-nTh35W/cherry-social/): No such file or directory in /home/web/site_folder/wp-content/themes/themexxxx/inc/class-tgm-plugin-activation.php on line 271

    Warning: array_keys() expects parameter 1 to be array, boolean given in /home/web/site_folder/wp-admin/includes/class-wp-upgrader.php on line 507

    At the end of this attempt, if I tried to update the plugin, I even find the plugin folder EMPTY! That is, the files of the old version are deleted but there are no new ones!

    When installing the plugin, I provide wordpress right FTP username and password: FTP access, reading and writing with these credentials work regularly.

    All folders have permissions 775, files have 664, while the owner of the entire space is username of the apache group (so owner = username:apache).

    I have also disabled selinux!

    Can anyone help me solve this problem?
    Thank you.

    Unable to update plugins
     
    #1

Share This Page

Web Hosting