Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Too many redirects problem on admin login after migrating to https

Discussion in 'Misc WordPress Requests' started by WordPress.org Forums », Feb 4, 2018.

  1. WordPress.org Forums »

    Guest

    Too many redirects problem on admin login after migrating to https, by

    Hi,
    I just migrated my site to https on a cloud server from online.net. Front-end works perfectly. But I can’t access the admin any more, it shows a too many redirect error.
    I did the following :
    – cleared the browser cache
    – deleted cookies
    – deactivated all plugins
    – deactivated all themes
    – made sure my home & site url are properly set to https://
    – set in wp-config.php define(‘FORCE_SSL_ADMIN’, true);
    – my htaccess is as follow:

    RewriteEngine On
    RewriteCond %{HTTP:HTTPS} !on
    RewriteRule (.*) https://%{SERVER_NAME}/$1 [QSA,L,R=301]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Nothing does.

    Strangely enough if I set the siteurl parameter in the database to http, deactivate the define(‘FORCE_SSL_ADMIN’, true); remove the https rewrite in the htaccess, then I get the login form without css as it is blocked by chrome, if I let it loads the risky scripts I get the login but I can’t get in. To get in I must deactivate the plugin “Force https by littlebizzy” which help me to fix the front end. But the problem with too many redirects to log in was present without this plugin installed.

    Any idea ?

    Too many redirects problem on admin login after migrating to https
     
    #1

Share This Page

Monarch Social Sharing Plugin