Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: Upload HTTP error – File uploads, WP breaks

Discussion in 'Misc WordPress Requests' started by cmb42, Dec 28, 2017.

  1. cmb42

    Guest

    Reply To: Upload HTTP error – File uploads, WP breaks, by cmb42


    • SOLUTION FOUND:

    Create file called .user.ini (if it doesn’t already exist.)
    Add the following lines. The second cured my issue, the first may solve others(optional):

    memory_limit = 128M
    max_execution_time = 300

    You can adjust the number as needed.
    Place the file in the root dir for the website (same dir as wp_config.php).
    ————————————————

    Thanks to the help of tech support at my provider, we have found a solution. All of these issues and solutions apply to MY PARTICULAR INSTALLATION. They may or may not work for yours.

    In my situation, changing the memory in the wp_config.php file with the line define( 'WP_MEMORY_LIMIT', '256M' ); did not work. However, putting the similar line in the .user.ini file did fix my issues with loading files.

    The .user.ini file appears to have been installed with WordFence. It is possible that it is installed with other plugins as well, I don’t know. BUT, by adding it with the memory limit setting, the upload issue seems to be resolved for me.

    TO THE DEVELOPERS:
    Since this issue seems tied to plugins and so many other issues, can you investigate why putting the memory limit in .user.ini works when putting it in wp-config.php fails? I suspect that this is a big clue to the real underlying problem.

    Thanks to everyone that tried to help. I’ll leave it open for a while to see what others have to say.

    IF THIS HELPS YOUR SITUATION, PLEASE LEAVE A COMMENT!

    Reply To: Upload HTTP error – File uploads, WP breaks
     
    #1

Share This Page

Monarch Social Sharing Plugin