Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: New created theme not loading style.css

Discussion in 'Misc WordPress Requests' started by stevecorwin, Feb 5, 2018.

  1. stevecorwin


    Reply To: New created theme not loading style.css, by stevecorwin

    I’m at my wits end here. I thought I was starting to have a handle on this stuff but I’ve spent 3 days trying to get my style.css to have any effect on my site and have failed. I’ve tried everything I could find online. The only thing I can think of to do is beg you guys for assistance. I’ve deleted my function.php file to start over. The following is the complete code I have so far for my style.css, header.php, footer.php, and index.php.

    *****index.php code:


    if ( have_posts() ) :
    while ( have_posts() ) : the_post(); ?>

    <article class=”post”>
    <h2>“><?php the_title() ?></h2>
    <?php the_content() ?>
    <?php endwhile;

    else :
    echo ‘<p>There are no posts!</p>’;




    *****style.css code:
    Theme Name: Prince
    Author: Steve Corwin
    Author URI: http://bridgetales.com
    Version: 1.0

    body {
    font-family: Arial, sans-serif;
    font-size: 16px;
    color: green;
    /* unvisited link */
    a:link {
    color: pink;

    /* visited link */
    a:visited {
    color: green;

    /* mouse over link */
    a:hover {
    color: hotpink;

    /* selected link */
    a:active {
    color: red;

    *****header.php code:
    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>

    <meta charset=”<?php bloginfo( ‘charset’ ); ?>”>
    <title><?php bloginfo( ‘name’ ); ?></title>
    <?php wp_head() ?>

    <body <?php body_class(); ?>>
    <div class=”container”>
    <header class=”site-header”>
    <h1>“><?php bloginfo( ‘name’ ); ?></h1>
    <h4><?php bloginfo( ‘description’ ); ?></h4>

    ****footer.php code:
    <h2>The Footer!</h2>
    <footer class=”site-footer”>
    <p><?php bloginfo( ‘name’ ) ?></p>
    </div> <!– closes <div class=container”> –>

    <?php wp_footer() ?>

    Can someone please tell me what I need to do from here to get the style.css to take effect?

    p.s. all above files located in root theme folder

    Reply To: New created theme not loading style.css

Share This Page

Monarch Social Sharing Plugin