Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: HTTPS Issue with WordPress

Discussion in 'Misc WordPress Requests' started by kyjus25, Oct 10, 2017.

  1. kyjus25

    Guest

    Reply To: HTTPS Issue with WordPress, by kyjus25

    Very strange. Does the WordPress admin bar show up on the front end of the site? That would prove you are successfully logged in. I would suggest creating a new user through WordPress (or setting it up directly through the database) and then upgrading it’s user role in the database to an admin. Some posts I’ve read online suggest that possibly the users table was corrupted in the move. Here’s some instructions on adding a user directly through the database if your WordPress doesn’t allow adding users through the front end.

    Check your .htaccess file in the root of your WordPress and make sure it doesn’t still have your old subdomain in there. It may be hidden, I know FileZilla will show it. Make sure anywhere inside that .htaccess file has “https://” instead of the old “http://”. It may be the default WordPress .htaccess where there are no http or https, but it may also have the subdomain example on WordPress’ codex. That looks like it may only be for multisite.

    Setting $_SERVER[‘HTTPS’]=’on’ and define(‘FORCE_SSL_ADMIN’, true) shouldn’t be necessary. The site should work just fine without it. You will, however, want to make sure all images and files are loaded in under HTTPS otherwise you’ll get a mixed content error. Adding this to the very top of my .htaccess file usually fixes this issue: Header always set Content-Security-Policy: upgrade-insecure-requests Otherwise you can just do a find/replace of all http://yourdomain to https://yourdomain using a plugin to correct your database

    Reply To: HTTPS Issue with WordPress
     
    #1

Share This Page

Web Hosting