Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: how to fix wcag2.0 AA error problem ? (I use original wordpress theme)

Discussion in 'Misc WordPress Requests' started by frankie422, Apr 6, 2018.

  1. frankie422

    Guest

    Reply To: how to fix wcag2.0 AA error problem ? (I use original wordpress theme), by frankie422

    I del all plugins & change theme to Twenty Seventeen, but same have this error?

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title>Web Accessibility Checker report</title>
    <meta name="author" content="AChecker - Web Accessibility Checker http://www.atutor.ca/achecker/" />

    <style type="text/css">
    ul {font-family: Arial; margin-bottom: 0px; margin-top: 0px; margin-right: 0px;}
    li.msg_err, li.msg_info { font-family: Arial; margin-bottom: 20px;list-style: none;}
    span.msg{font-family: Arial; line-height: 150%;}
    code.input { margin-bottom: 2ex; background-color: #F8F8F8; line-height: 130%;}
    span.err_type{ padding: .1em .5em; font-size: smaller;}
    span.info_msg { line-height: 100%; color: blue; padding: 1em 1em; font-size: large; font-weight: bold;}
    span.congrats_msg { line-height: 120%; color: green; padding: 1em 1em; font-size: large; font-weight: bold; white-space: nowrap;}
    </style>
    </head>
    <body>
    <p>
    <strong>Result: </strong>
    <span style="background-color: red; border: solid green; padding-right: 1em; padding-left: 1em">FAIL</span>&nbsp;&nbsp;
    <span style="color:red"><span style="font-weight: bold;">2 Errors&nbsp;&nbsp;</span></span>
    <strong><br />
    <strong>Guides: </strong><a title="WCAG 2.0 (Level AA)(link opens in a new window)" target="_new" href="https://achecker.ca/guideline/view_guideline.php?id=8">WCAG 2.0 (Level AA)(link opens in a new window)</a>&nbsp;&nbsp;
    </p>
    <h3>Accessibility Review</h3>
    <h4>Errors</h4>
    <div id="errors" style="margin-top:1em">
    <ul>
    <li class="msg_err">
    <span class="err_type"><img src="https://achecker.ca/images/error.png" alt="Error" title="Error" width="15" height="15" /></span>
    <em>Line 1, Column 1</em>:
    <span class="msg">
    <a href="https://achecker.ca/checker/suggestion.php?id=48"
    onclick="AChecker.popup('https://achecker.ca/checker/suggestion.php?id=48'); return false;"
    target="_new">Document language not identified.</a>
    </span>
    <pre><code class="input"><html><body><script type=&quot;text/javascript&quot; src=&quot;/aes.js&quot; ></script><script>function toNumbers(d){var ...</code></pre>

    <p class="helpwanted">
    </p>
    <span style="font-weight:bold">Repair: </span>For HTML documents add the lang attribute and a valid ISO-639-1 two letter language code to the opening HTML element. For XHTML documents add both the lang and xmllang attributes with a valid ISO-639-1 two letter language code to the opening HTML element.



    </li>
    <li class="msg_err">
    <span class="err_type"><img src="https://achecker.ca/images/error.png" alt="Error" title="Error" width="15" height="15" /></span>
    <em>Line 1, Column 1</em>:
    <span class="msg">
    <a href="https://achecker.ca/checker/suggestion.php?id=49"
    onclick="AChecker.popup('https://achecker.ca/checker/suggestion.php?id=49'); return false;"
    target="_new">Document has invalid language code.</a>
    </span>
    <pre><code class="input"><html><body><script type=&quot;text/javascript&quot; src=&quot;/aes.js&quot; ></script><script>function toNumbers(d){var ...</code></pre>

    <p class="helpwanted">
    </p>
    <span style="font-weight:bold">Repair: </span>Add a valid 2 letter or 3 letter language code as defined in the ISO 639 specification to the HTML 'lang' attribute. For XHTML, both 'lang' and 'xml:lang' must be set.



    </li>
    </ul>
    </div>

    </body></html>

    Reply To: how to fix wcag2.0 AA error problem ? (I use original wordpress theme)
     
    #1

Share This Page

Monarch Social Sharing Plugin