Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: For SiteGround users, how did you manage to reduce CPU/executed files?

Discussion in 'Misc WordPress Requests' started by ivanatanasov, Jan 2, 2018.

  1. ivanatanasov


    Reply To: For SiteGround users, how did you manage to reduce CPU/executed files?, by ivanatanasov


    My name is Ivan Atanasov, I am part of the Senior Support Team at SiteGround. I saw this post and took the liberty of checking your websites.

    If you are interested, I would like to share some concerns I have for the performance of the websites starting with the caching services.

    SG Optimizer is installed and active on all of the mentioned installations, and SuperCacher is active for all levels of cache. However, I noticed that you are also using W3 Total Cache. Meaning, two plugins will be gathering cache for your website(s).

    For the plugins to coexist on your WordPress installations and still work properly, you should choose which plugin you would like to use for page caching. While W3 Total Cache uses file-based caching method (includes the cache for your website in files) SG Optimizer will utilise the server’s Memory which is considered the faster and more reliable way of presenting cached content.

    You can try to disable the full page caching for W3 Total Cache and still use all the rest of it’s functions along with SG Optimizer which will cache your website(s). (Guide: https://code.tutsplus.com/articles/configuring-w3-total-cache-advance-page-cache-i–cms-21148).

    While reviewing the situation, I also noticed that in several of your tickets, we advised on the performance issues mentioning the access logs of your websites. Correcting the caching settings should help with this.

    Another matter I would like to address is the situation with your WordPress Scheduled Events. I noticed that some of them coincide and are being ran at the same time. Meaning, your apps are executing a scheduled event at the same time which could take up a lot of your resources and exhaust the limits.

    To add to this, I found a slow query (I am reluctant to it share this in a public discussion). The presence of slow queries in your database could lead to the WP-Cron being stuck. Slow queries consume CPU time as well. The good news is that the query was last executed 13 hours ago. Still, a review of the WordPress Scheduled Events is advisable.

    If you need to discuss this with our team, don’t hesitate to post a Support Ticket from your User Area.

    Reply To: For SiteGround users, how did you manage to reduce CPU/executed files?

Share This Page

Monarch Social Sharing Plugin