Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: CSS weird bug

Discussion in 'Misc WordPress Requests' started by josipwp, Oct 8, 2017.

  1. josipwp

    Guest

    Reply To: CSS weird bug, by josipwp

    Well, I have two, this one is from ‘higher tier map, /public_html/.htaccess:

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^sailboatrc.com$ [NC,OR]
    RewriteCond %{HTTP_HOST} ^www.sailboatrc.com$
    RewriteCond %{REQUEST_URI} !sailboatrc.com/
    RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
    RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
    RewriteRule (.*) /sailboatrc.com/$1 [L]

    and this one is from subfolder, public_html/public_html/sailboatrc.com:

    # HTTPS forced by SG-Optimizer
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END HTTPS
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    BUT, this was already solved with my Customer Support member who resolved it this way:


    “Thank you for getting back Josip,

    I have removed the redirection entries inside your .htaccess and replaced them with the default WordPress rewrite rules:

    Code:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    After doing that, the redirect to the non-existing folder is gone, and you can verify this by clearing your browser’s cache. You can also check this online tool for the results:

    https://geopeeker.com/fetch/?url=WWW.SAILBOATRC.COM

    And the reason why the shop page is not showing properly is because a file is missing from your website:

    https://sailboatrc.com/wp-content/uploads/fusion-scripts/b48236d78e83938db8ba69ec655fce7d.js

    This file is opened when accessing the shop page but since the files does not exist, the shop is not loading properly. If the website was previously working, we would advise you to run a backup restore for a specific date within 30 calendar days back. Please note that it is not recommended for two applications to share a single database as the changes in one of the websites can break the functionality of the other one.

    If there is anything else we can help you with, please open a new ticket.”

    AFTER we did that, the “Double link problem” was gone, but my Shop page was messed up with some bug, and then we are back to my first post up above in which I have explained that already…

    Reply To: CSS weird bug
     
    #1

Share This Page

Web Hosting