Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: Could not establish a secure connection

Discussion in 'Misc WordPress Requests' started by Steve Stern, Jan 2, 2018.

  1. Steve Stern

    Guest

    Reply To: Could not establish a secure connection, by Steve Stern

    What do you see if you type

    curl -v https://wordpress.org/latest.tar.gz > /dev/null

    I get

    $ curl -v https://wordpress.org/latest.tar.gz > /dev/null
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0* Trying 66.155.40.250...
    * TCP_NODELAY set
    * Connected to wordpress.org (66.155.40.250) port 443 (#0)
    * ALPN, offering h2
    * ALPN, offering http/1.1
    * Cipher selection: PROFILE=SYSTEM
    * successfully set certificate verify locations:
    * CAfile: /etc/pki/tls/certs/ca-bundle.crt
    CApath: none
    } [5 bytes data]
    * TLSv1.2 (OUT), TLS handshake, Client hello (1):
    } [512 bytes data]
    * TLSv1.2 (IN), TLS handshake, Server hello (2):
    { [102 bytes data]
    * TLSv1.2 (IN), TLS handshake, Certificate (11):
    { [3740 bytes data]
    * TLSv1.2 (IN), TLS handshake, Server key exchange (12):
    { [333 bytes data]
    * TLSv1.2 (IN), TLS handshake, Server finished (14):
    { [4 bytes data]
    * TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
    } [70 bytes data]
    * TLSv1.2 (OUT), TLS change cipher, Client hello (1):
    } [1 bytes data]
    * TLSv1.2 (OUT), TLS handshake, Finished (20):
    } [16 bytes data]
    * TLSv1.2 (IN), TLS handshake, Finished (20):
    { [16 bytes data]
    * SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
    * ALPN, server accepted to use h2
    * Server certificate:
    * subject: OU=Domain Control Validated; CN=*.wordpress.org
    * start date: Nov 6 17:42:01 2017 GMT
    * expire date: Dec 15 20:11:21 2020 GMT
    * subjectAltName: host "wordpress.org" matched cert's "wordpress.org"
    * issuer: C=US; ST=Arizona; L=Scottsdale; O=GoDaddy.com, Inc.; OU=http://certs.godaddy.com/repository/; CN=Go Daddy Secure Certificate Authority - G2
    * SSL certificate verify ok.
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0* Using HTTP2, server supports multi-use
    * Connection state changed (HTTP/2 confirmed)
    * Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
    } [5 bytes data]
    * Using Stream ID: 1 (easy handle 0x5613cedc7260)
    } [5 bytes data]
    > GET /latest.tar.gz HTTP/2
    > Host: wordpress.org
    > User-Agent: curl/7.55.1
    > Accept: */*
    >
    { [5 bytes data]
    * Connection state changed (MAX_CONCURRENT_STREAMS updated)!
    } [5 bytes data]
    < HTTP/2 200
    < server: nginx
    < date: Tue, 02 Jan 2018 16:21:15 GMT
    < content-type: application/octet-stream
    < content-length: 9638827
    < cache-control: private
    < content-disposition: attachment; filename=wordpress-4.9.1.tar.gz
    < last-modified: Wed, 29 Nov 2017 19:07:17 GMT
    < x-frame-options: SAMEORIGIN
    < content-md5: 111ecbfc98633103e1fc1105c0c00c76
    < x-nc: HIT lax 250
    < accept-ranges: bytes
    <
    { [1108 bytes data]
    100 9412k 100 9412k 0 0 4706k 0 0:00:02 0:00:02 --:--:-- 3478k
    * Connection #0 to host wordpress.org left intact

    Reply To: Could not establish a secure connection
     
    #1

Share This Page

Monarch Social Sharing Plugin