Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: Can’t edit main theme php files after upgrading to 4.9

Discussion in 'Misc WordPress Requests' started by Pádraig Ó Beirn, Nov 19, 2017.

  1. Pádraig Ó Beirn

    Guest

    Reply To: Can’t edit main theme php files after upgrading to 4.9, by Pádraig Ó Beirn

    Thanks @dpsachou for letting us know it was a plugin.
    It would be great @petrichorpost if you could let us know how you resolved it.

    If it’s an emergency @t10cricket update your header.php offline and upload via ftp.
    To find out where exactly the problem lies I would suggest following these steps:

    1. Download the free Health Check plugin – https://wordpress.org/plugins/health-check/
    2. Make a backup of your website (I recommend Updraftplus – https://wordpress.org/plugins/updraftplus/)
    3. Run a Health Check using the Health Check plugin. Do any fields have a red X? You may see a message which reads: “Unable to perform a loopback request to your site, this may prevent WP_Cron from working, along with theme and plugin editors.”
    4. Download the Twenty Seventeen theme and activate it. Run the Health Check again. Do you see a loopback or any other failed response? If so, disable all plugins (except Health Check) and run the Health Check. You may see “The loopback request to your site completed successfully.” This probably means one of your plugins is the problem: re-activate them one by one, running Health Check each time, or in small groups if you have lots of plugins, to isolate the problem.
    5. If you still see the loopback request error in Health Check post some of your server debug information here (see mine below) including your webhost, which hosting package, server, php and mysql version.

    @clorith With all plugins disabled and the Twenty Seventeen theme activated I still get the following error on trying to edit a theme or plugin php file: “Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.” Also getting a failed loopback request in Health Check with all plugins deactivated. Is there anything I can ask my host to check? Thanks in advance for any suggestions.

    Just so you don’t have to search for it again in this thread, here are my details:

    Webhost: Blacknight (Maximus shared hosting package)
    Exact Error: Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.
    When does it occur?: A few seconds after clicking the Update button on editing an active Theme php file or active plugin php files (css or txt files are not affected) in the WP theme or plugin editor.

    Error still occurs with plugins de-activated and 2017 theme activated. Re-activated plugins and ran Health Check with the following results:

    Server architecture: Linux 2.6.32-673.26.1.lve1.4.30.el6.x86_64 x86_64
    PHP Version: 7.0.25 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 2048
    PHP time limit: 120
    PHP memory limit: 256M
    Upload max filesize: 32M
    PHP post max size: 32M
    cURL Version: 7.54.0 OpenSSL/1.0.2k
    SUHOSIN installed: No
    Is the Imagick library available: No

    MySQL
    Server version: 5.5.57
    Client version: 5.6.37

    Your PHP install supports JSON.
    Your MySQL version supports utf8mb4
    WordPress.org is reachable from your server.
    You are using HTTPS to access this website.
    Your WordPress install can communicate securely with other services.
    No version control systems were detected.
    Your installation of WordPress doesn’t require FTP credentials to perform updates.
    All of your WordPress files are writable.

    – A scheduled event (nxs_querypost_event) has failed to run. Your site still works, but this may indicate that scheduling posts or automated updates may not work as intended.

    x The WP_AUTO_UPDATE_CORE constant is defined and enabled. [I have this set intentionally].
    x WordPress security and maintenance releases are blocked by define( ‘WP_AUTO_UPDATE_CORE’, false );. [I have this set intentionally so I can review updates on a test site first]

    x Unable to perform a loopback request to your site, this may prevent WP_Cron from working, along with theme and plugin editors.

    Reply To: Can’t edit main theme php files after upgrading to 4.9
     
    #1

Share This Page

Web Hosting