Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: “Sorry you’re not allowed to access this page” after migrating to https

Discussion in 'Misc WordPress Requests' started by akshatjiwan, Oct 27, 2017.

  1. akshatjiwan

    Guest

    Reply To: “Sorry you’re not allowed to access this page” after migrating to https, by akshatjiwan

    Thank you once more Vince! You’re right I’ll have to do some experimentation with multiple parameters in order to find out the root cause. But thank you for pointing me in the right direction. I’ve managed to recreate the “bug” on my dev server so making some of these changes has become a lot easier now that I don’t have to worry about permanently breaking anything on production. Its a start I guess

    >what is the behavior when you try to load HTTPS without those lines present?

    Well the behavior is exactly like you pointed out. I get infinite redirects when I go to wp_login.php page.

    >Does that behavior change when you try to load interior links versus the home page, or when you try to log into wp-admin?

    The home page and other blog posts work perfectly fine (except in the case when I don’t change all the urls in the database the browser blocks mixed content served over http) The issues that I’m talking about only occur when I try to login to access admin pages. And since I haven’t managed to get past the login screen I can’t really say what happens when the admin pages show up.

    >What about point #3 in my earlier reply – have you tried loading the browser’s developer tools and watching the Network tab to view all HTTP/HTTPS requests and see any errors in the console? If so, what have you seen?

    I tired your suggestion after typing my response previously and although there were no errors on the console I discovered something else that raised more questions. A lot of 302 responses were being returned. In the nginx configuration a proxy cache is being used. I’m not able to actually query the items in the cache but it might very well be possible that when I move from one scheme to the other the cached objects are returned and they somehow cause an error? So that is one more line to investigate.

    Another idea that I have stumbled upon is to use wp rest api. I want to see how things change when I try to login using the api vs the on screen UI. Maybe I’ll uncover something new that will help me solve the main problem.

    Looks like this one is going to take some time But I’ll keep this thread open and update you on any new things I discover.

    As a last resort there is always an option of changing the configuration files themselves. I’ve ashley rich’s nginx configuration files on github (https://github.com/A5hleyRich/wordpress-nginx) and they look quite good. I’ll try to see if the problem resolves itself with that configuration.

    Once more thank you so much for your responses. It gave me ideas on how to attack the problem.

    Thanks,
    Akshat

    Reply To: “Sorry you’re not allowed to access this page” after migrating to https
     
    #1

Share This Page

Web Hosting