Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Reply To: “Sorry you’re not allowed to access this page” after migrating to https

Discussion in 'Misc WordPress Requests' started by vincek1, Oct 27, 2017.

  1. vincek1

    Guest

    Reply To: “Sorry you’re not allowed to access this page” after migrating to https, by vincek1

    Hello Akshat!

    I have not seen this specific behavior before, but I have seen this error message as well as conflicting behavior between HTTP and HTTPS. Here are some notes that I hope will be helpful in your research:

    1. The “Sorry you’re not allowed to access this page” is typically seen when a user doesn’t have any role assigned to it, or is assigned a role that no longer exists for some reason, usually due to corruption in a database table. However, since you are able to login successfully using HTTP…

    2. I have usually seen an issue with a mismatch in HTTP versus HTTPS behavior when the web service settings (i.e. your nginx configs) accidentally point to a different web directory path.

    3. Assuming the above is not the case, perhaps an HTTPS request is not resolving correctly during the login process. Have you tried opening the Developer Tools console in your browser while attempting both the HTTPS as well as the HTTP login to compare and see if any errors are reported?

    4. The wp-config.php code appears to be fine at first glance, but it isn’t strictly necessary to make HTTPS work; it’s only there to force HTTP attempts to be loaded as HTTPS. Have you tried removing this code and testing HTTPS again specifically? (I assume you have to remove the code when you test HTTP and login successfully.)

    This is my first response to a post on these forums, so please forgive any mistakes or confusing text above! If you need me to re-explain anything please let me know.

    Hope this helps!
    – Vince

    Reply To: “Sorry you’re not allowed to access this page” after migrating to https
     
    #1

Share This Page

Web Hosting