Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Plugin updates broken, looking for FTP credentials (related to SSH/SSL/FastCGI)

Discussion in 'Misc WordPress Requests' started by Rev. Voodoo, Dec 22, 2017.

  1. Rev. Voodoo


    Plugin updates broken, looking for FTP credentials (related to SSH/SSL/FastCGI), by Rev. Voodoo

    Haven’t needed help in years!! But I broke it. I know WP, I don’t know server. Running Debian 9, Apache2. I’m on Google Compute Engine, so no phpmyadmin… it’s all CLI for me which is fun/tough.

    Trying to drop my resource usage and I upgraded to PHP7. To benefit more I enabled FastCGI. Then I added letsencrypt for all my sites – install in question is a multisite install.

    No FTP on GCE, so when I first installed, I followed this tutorial, a year back to get updates working over SSH. https://www.digitalocean.com/commun...ates-and-installations-in-wordpress-on-ubuntu

    That fixed things and my plugin and core updates worked again. I updated from PHP5 to PHP7 but at some point somehow, my server went back to PHP5. I recently activated 7 again.

    Then I turned on FastCGI PHP-FPM … that all worked. Same time I did that I got SSL enabled using letsencrpyt. That went amazingly well actually.

    Until I tried to update my plugins, I get the FTP credentials required screen, with fields greyed out since I have the wp-config settings to do SSH.

    I went back through that tutorial linked above to make sure my SSH setup was proper with all the changes. That is configured on my PHP7 install, but it still doesn’t work.

    So, it could be related to the PHP7, but that seems least likely. I’m almost certain I was able to update with PHP7 before.

    It could also be related to FastCGI since I did that at the same time as SSL… this is where my ability breaks down, I don’t know enough to know if that could be a problem.

    Most likely, to my novice server admin mind, is that enabling SSL did it.

    I’ve done my due diligence on the Google machine, but I’m stumped. Does anyone know if there are any special accommodations I need to make after SSL install to make the SSH updates work correctly?

    Plugin updates broken, looking for FTP credentials (related to SSH/SSL/FastCGI)

Share This Page

Monarch Social Sharing Plugin