Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix permalinks on IIS

Discussion in 'Misc WordPress Requests' started by WordPress.org Forums », Jan 25, 2018.

  1. WordPress.org Forums »

    Guest

    permalinks on IIS, by

    I recently had need for a host to restore a site from a backup and when it came back up the permalinks appear not to be working.

    I have bumped them a couple of times in stting>permalinks but nothing has changed

    There is a notice in the dash board about web.config needing to be updated, but neither I nor the host seems to know how to do that – should wordpress do this itself much as it does .htaccess

    In any case this is the web.config file. Can any one help truble shoot this

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name=”wordpress” patternSyntax=”Wildcard”>
    <match url=”*” />
    <conditions>
    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” negate=”true” />
    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” negate=”true” />
    </conditions>
    <action type=”Rewrite” url=”index.php” />
    </rule>
    <rule name=”Plesk. WordPress redirect wpConfigRule #73145cbb-5261-473c-b6c7-d9fd3123fbe2″ stopProcessing=”true”>
    <match url=”^wp-config.php$” ignoreCase=”false” />
    <action type=”CustomResponse” statusCode=”403″ statusReason=”Forbidden” statusDescription=”Forbidden” />
    </rule>
    <rule name=”Plesk. WordPress redirect wpContentRule #443a2663-c0ef-4391-8f1c-1618e5cd9f05″ stopProcessing=”true”>
    <match url=”^wp-content/.+\.php$” ignoreCase=”false” />
    <action type=”CustomResponse” statusCode=”403″ statusReason=”Forbidden” statusDescription=”Forbidden” />
    </rule>
    <rule name=”Plesk. WordPress redirect wpIncludesRule #fd6af2e7-29db-4137-94fb-69b50b43e527″ stopProcessing=”true”>
    <match url=”^wp-includes/.+\.php$” ignoreCase=”false” />
    <action type=”CustomResponse” statusCode=”403″ statusReason=”Forbidden” statusDescription=”Forbidden” />
    </rule></rules>
    </rewrite>
    <directoryBrowse enabled=”false” />
    </system.webServer>
    </configuration>

    permalinks on IIS
     
    #1

Share This Page

Monarch Social Sharing Plugin