Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Permalink structure not being followed, results in 404s

Discussion in 'Misc WordPress Requests' started by csburdick, Apr 4, 2018.

  1. csburdick

    Guest

    Permalink structure not being followed, results in 404s, by csburdick

    I recently started the blog section on my site https://www.bestroboadvisors.org/ and I’m wanting to have all posts have the permalink structure “/blog/%postname%/”

    That’s what I have set in my permalink settings, along with the category base “blog”:

    https://i.gyazo.com/9635d63fd9111e3eb3bc0740c3ceefbc.png

    However, neither of those are working properly.

    When I try to go to a blog post, which should be https://www.bestroboadvisors.org/blog/investing-to-get-out-of-debt/, it redirects to https://www.bestroboadvisors.org/investing-to-get-out-of-debt/ but it’s a “Page Not Found” error there. The /blog/ base is shown in the post page: https://i.gyazo.com/42f71819ab6d7ccafae6b995a6e23595.png but the URL doesn’t work.

    Additionally, the “blog” category base isn’t working. For example it should be https://www.bestroboadvisors.org/blog/personal-finance/ but that just redirects to https://www.bestroboadvisors.org/personal-finance/ (which at least does work).

    Thank you for any help!
    Chris

    Permalink structure not being followed, results in 404s
     
    #1

Share This Page

Monarch Social Sharing Plugin