Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix No internet connection (i.e. no updates, no plugins)

Discussion in 'Misc WordPress Requests' started by jberner, Jan 29, 2018.

  1. jberner


    No internet connection (i.e. no updates, no plugins), by jberner

    Hello all,

    I have a WP installation that won’t talk to the internet.

    Here’s what I have done so far:

    1) installed a Ubuntu 16.04.03 LTS server with the LAMP package and phpmyadmin on virtual machine
    2) sudo apt-get update && sudo apt dist-upgrade
    3) configured MySQL
    4) sudo apt-get install wordpress
    5) configured apache so that http://myserver.mydomain.local/wp points to the WP homepage
    6) completed the WP configuration wizard

    Up to here: no problems. WP loads, I can login, I can configure settings. Great.

    But here’s the problem: the server is behind a proxy and can’t connect directly to the internet. So I added these lines to /usr/share/wordpress/wp-config.php
    /* Configure proxy Server */
    define(‘WP_PROXY_HOST’, ‘’);
    define(‘WP_PROXY_PORT’, ‘3128’);
    define(‘WP_PROXY_USERNAME’, ”);
    define(‘WP_PROXY_PASSWORD’, ”);
    define(‘WP_PROXY_BYPASS_HOSTS’, ‘localhost’);
    define(‘WP_USEPROXY’, ‘TRUE’);

    Restarted the server and nothing. Still doesn’t connect. I tried to do an update to WP 4.9.2 but the server doesn’t find it automatically. Instead it says 4.4.2 is the latest version (which I think is a bug, I would think that I get a warning if the check fails). Trying to install plugins directs to a page where I’m asked to enter an ftp-server address.

    This is what my Squid says when WP tries to connect to the internet:
    IP_OF_MY_WP_SERVER – – [26/Jan/2018:15:44:08 +0100] “POST https://api.wordpress.org/plugins/update-check/1.1/ HTTP/0.0″ 501 3861 NONE
    IP_OF_MY_WP_SERVER – – [26/Jan/2018:15:44:08 +0100] “POST https://api.wordpress.org/themes/update-check/1.1/ HTTP/0.0″ 501 3857 NONE
    IP_OF_MY_WP_SERVER – – [26/Jan/2018:15:44:08 +0100] “POST https://api.wordpress.org/core/version-check/1.7/? HTTP/0.0″ 501 4157 NONE

    Googling for the 501 error told me to install php5-curl, which isn’t necessary because it’s been superseded by another package which is already installed.

    Another thing I did was to add
    export http_proxy=http://IP_OF_PROXY:3128
    export https_proxy=http://IP_OF_PROXY:3128
    export ftp_proxy=http://IP_OF_PROXY:3128
    export HTTP_PROXY=$http_proxy
    export HTTPS_PROXY=$https_proxy
    export FTP_PROXY=$ftp_proxy

    to /etc/profile to allow the OS to talk to the internet, which works great. apt-get works, wget works.

    Does anyone have an idea what to do? I’m at my wits end.


    No internet connection (i.e. no updates, no plugins)

Share This Page

Monarch Social Sharing Plugin