Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix My web is not indexed by Google – robots.txt or sitemap xmls

Discussion in 'Misc WordPress Requests' started by coffeetalkingnet, Dec 3, 2017.

  1. coffeetalkingnet

    Guest

    My web is not indexed by Google – robots.txt or sitemap xmls, by coffeetalkingnet

    Hello,

    I have a new website, http://www.coffeetalking.net that seems that is not being indexed by Google: I check it by finding in google “site:www.coffeetalking.net”, but I always get a message saying “No information is available for this page. Learn why”.

    And then it says “the page is blocked by a robots.txt file entry”, but I doubt it because I’ve created this file like this:

    User-Agent: *
    Allow: /?display=wide
    Allow: /wp-content/uploads/
    Disallow: /wp-content/plugins/
    Disallow: /readme.html
    Disallow: /refer/

    Sitemap: http://coffeetalking.net/post-sitemap.xml
    Sitemap: http://coffeetalking.net/page-sitemap.xml
    Sitemap: http://coffeetalking.net/deals-sitemap.xml
    Sitemap: http://coffeetalking.net/hosting-sitemap.xml
    And I also have my sitemap files generated by the Yoast SEO plugin as indicated in the robots.txt file:
    i.e., the post-sitemap file contains:

    URL Images Last Mod.
    http://coffeetalking.net/en/contactenglish/ 0
    http://coffeetalking.net/en/2017/12/01/like-understand-everything/ 0 2017-12-02 15:25 +00:00
    http://coffeetalking.net/es/2017/12/01/gustaria-poder-entenderlo-todo/ 0 2017-12-02 15:25 +00:00
    http://coffeetalking.net/es/2017/11/30/porque-existe-algo-en-vez-de-nada/ 0 2017-12-02 15:53 +00:00
    http://coffeetalking.net/en/2017/11/29/why-is-there-something-instead-of-nothing/ 0 2017-12-02 15:55 +00:00

    My site had also sitemap xml being generated by the jetpack plugin before, but I’ve already deactivated it, so it’s only being generated by Yoast plugin.

    Another thing that worries me is that, from the google search console, when I try to force Google to index the site with the option “Fetch as google”, I get an exclamation sign and a “Redirected” status, from
    http://coffeetalking.net/ to http://coffeetalking.net/en/

    I suspect that is caused by the plugin Polylang.

    If instead of using http://coffeetalking.net/ , I use http://coffeetalking.net/es/ and http://coffeetalking.net/en/
    , i get an OK green status check with “partial” keyword. So, I don’t know if I have to do something different to make my site indexed
    – Another thing that I don’t understand is that if I try to access to the sitemap xmls by the url prededed with www, they don’t work, i.e. http://www.coffeetalking.net/post-sitemap.xml, I get a BLANK page (NOT page not found), but it works without the www prefix)
    – Also I don’t understand why the forur sitemap xml files are not visible trough ftp on the root folder of my site. Are they some kind of ‘virtual’ files ?

    Thanks in advance for all your help !!!

    My web is not indexed by Google – robots.txt or sitemap xmls
     
    #1

Share This Page

Web Hosting