Web Hosting
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Importing Database – database imports, but nothing imported appears in site

Discussion in 'Misc WordPress Requests' started by yetiboy, Nov 13, 2017.

  1. yetiboy

    Guest

    Importing Database – database imports, but nothing imported appears in site, by yetiboy

    I’ve recently moved hosts, and booboo’ed – I backed up the site, but forgot to export the database (I know, unbelievably stupid) and have already told my previous host to wipe my data so there is zero possibility of recovering it from them.

    However, I DO have backups from several years ago – and since I haven’t actually updated the site, all posts are available.

    I’ve followed the following steps:
    1. Installed WordPress. When doing so, I attempted both with using the default database name and prefixes provided by the installer AND tried using the database name and prefix that is found in the .sql backup file.
    2. Attempted viewing site – shows the basic “Hello World” installation.
    3. Import database from .sql backups. When doing so, it adds all of the information to the database but creates duplicates of all the tables. ie. the installation creates a abc3_posts table (abc3 being the default prefix provided by the installer), the import creates another table called abc3_xyz1_posts (xyz1 being the prefix found in the backup).

    So I now have double the number of tables, but only the installer set of data is being shown on the site. The imported posts ARE there – I can see them when I go into abc3_xyz1_posts – but they don’t appear on the site.

    I’m guessing I’m either missing something simple in the installation, or (and I really hope this isn’t the issue) it’s a problem with the age of the .sql file and it just doesn’t import properly with this version of WordPress.

    Can anyone help? I’ve been tearing my hair out trying to figure this out. Thanks!

    Importing Database – database imports, but nothing imported appears in site
     
    #1

Share This Page

Web Hosting