Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Blog Posts on Facebook don’t work on mobile

Discussion in 'Misc WordPress Requests' started by mjmpublishing, Dec 10, 2017.

  1. mjmpublishing


    Blog Posts on Facebook don’t work on mobile, by mjmpublishing

    Hi, This is driving me crazy. I’ve got Avada Theme, responsive is turned on, all other mobile and blog settings are set properly as far as I can tell. I’ve got Jetpack but mobile is not on, I do not like it’s theme. It’s social is on and set. I’ve got Yoast SEO and it’s social is setup. I’m using Anymobile Theme Switcher plug in to retain the Avada Theme.
    Ok, here is the weird problem. When I create a blog post, it does automatically go to FB and others when it is published. However – only in FB and only on mobile, when you click the link or the post of the blog item it goes to a blank background image of my theme! It works fine on my desktop Windows 10.
    The blog is at https://www.motorcycletimes.com/nog-posts-2/ but on my IOS phone 5S I see the address it’s using as just http://www.motorcycletimes.com so I think this is the conflict but I’ve gone over and over all the settings. I cant figure out where or how to correct this.
    Obviously I know next to nothing about CSS and etc so I’m really stuck. any help is greatly appreciated!

    Blog Posts on Facebook don’t work on mobile

Share This Page

Monarch Social Sharing Plugin