Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix Another unable to communicate to site when editing PHP files thread

Discussion in 'Misc WordPress Requests' started by rlees85, Feb 18, 2018.

  1. rlees85


    Another unable to communicate to site when editing PHP files thread, by rlees85

    Since: https://wordpress.org/support/topic/cant-edit-main-theme-php-files-after-upgrading-to-4-9/ was mistakenly closed.

    I think a thread “approaching double digits” is a terrible reason to close it. The fact its that long just goes to show how bad the WordPress teams decision was to implement this “check”.

    So far, I’ve tried: disabling opcache, disabling all plugins. There are only two things left that could be causing WordPress to refuse to update .php files via the editor:

    1. modpagespeed – performance or your crappy check? performance please.
    2. nginx
    3. php v7 – I assume you support PHP 7, not going to downgrade to php 3 over this anyway….

    Please consider the following:

    Nearly ALL installed plugins that are conflicting with this check add MUCH more value to a WordPress site than this check.

    ALL themes again add much more value to a site than this crappy check.

    Things like modpagespeed, cdn, etc again, more value then this check.

    If you don’t play nice with nginx well done on breaking compatibility with one of two major web servers.

    You NEED to roll back this stupid check. You have seriously annoyed off a whole load of your user base for a check that adds very very little value. At the absolute minimum, add an option to disable it.

    Anyone else reading this: most tidy, clean and convenient solution for this was to:

    1. Install a file manager plugin
    2. Edit /wp-admin/includes/file.php (line: 492 as of WordPress 4.9.4)
    if ( $is_active && ‘php’ === $extension ) {

    change to:

    if ( $is_active && ‘turn_off_useless_check’ == $extension ) {

    3. Disable your file manager plugin until you update WordPress next.
    4. Enjoy.

    We all appreciate WordPress being a free word-leading platform. But as the moderator said in the other thread: “this is out of hand”. Yes, it is. Please stop being stubborn.

    Oh and WP CRON might not be working? Its default implementation is an abomination anyway so I trigger that using crond on the host itself.

    This is not an “ask for help” on my site in question. It is purely to add noise to the issue and point out that most of the userbase is now editing files using FTP (pukes) as your solutions like “reverting to twentyseventeen” ruins their site.

    Another unable to communicate to site when editing PHP files thread

Share This Page

Monarch Social Sharing Plugin