Divi WordPress Theme
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WordPress fix After update to SSL Post format archive links do not work

Discussion in 'Misc WordPress Requests' started by Nick Bohle, Apr 2, 2018.

  1. Nick Bohle

    Guest

    After update to SSL Post format archive links do not work, by Nick Bohle

    Dear all,

    today, I decided to encrypt my site with a SSL certificate offered by my provider.

    For now, I did the following:

    – Updated wp-config.php
    define('FORCE_SSL_ADMIN', true);

    – Updated the links in WP Admin / Settings / General
    http://mysite.com to https://mysite.com

    – Used the plugin Better Search Replace to also update the database (after making a back-up and a test run)
    http://mysite.com to https://mysite.com

    Now I am stuck with the following problem.

    The normal site and archive links (Year, month, dates, categories, tags) work fine, but the link to the post format type do not work anymore.

    I use the post format as a submenu in my main navigation:

    https://mysite.com
    – – https://mysite.com/type/standard (with plugin Query Standard Format Posts)
    – – https://mysite.com/type/image
    – – https://mysite.com/type/video
    – – https://mysite.com/type/gallery
    – – https://mysite.com/type/quote

    After updating the link to SSL, the menu items stopped working. Also a direct entry in the address line of the browser creates a 404 error.

    Is their any issue with this query “type” of post format and SSL? The strange thing is that (as mentioned above) all other archive / navigation links work with https.

    Thanks for your support.

    After update to SSL Post format archive links do not work
     
    #1

Share This Page

Monarch Social Sharing Plugin